frame-relay: bridging over a frame-relay back to back connection

In this scenario I will show you how to bridge ethernet frames over a frame-relay connection. We have four routers in our topology. Two of them are the WAN routers connected via frame-relay back to back and two remote sites that want to establish a direct transparent connection to each other to create an OSPF adjacency.

Here is the topology:

Goal:
– bridge ethernet frames from R3 to R4.

So first step is to create our back to back connection in the WAN. To do this we need to configure the frame-relay interfaces of R1 and R2. Detailed instructions on how to do back to back connections you can find in a different post in the blog.


R1(config)#int s0/0
R1(config-if)#no shut
R1(config-if)#encapsulation frame-relay
R1(config-if)#no keepalive
R1(config-if)#frame-relay interface-dlci 102

R2(config)#int s0/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#no shut
R2(config-if)#no keepalive
R2(config-if)#frame-relay interface-dlci 102

The next step I will do is to prepare R3 and R4 for connectivity which means the configuration of the FastEthernet interfaces.


R3(config)#int fa0/0
R3(config-if)#ip address 172.16.43.1 255.255.255.252
R3(config-if)#no shut
R3(config-if)#ip ospf 1 are 0

R4(config)#int fa0/0
R4(config-if)#ip address 172.16.43.2 255.255.255.252
R4(config-if)#no shut
R4(config-if)#ip ospf 1 are 0

We must not forget the FastEthernet interfaces of R1 and R2


R1(config)#int fa0/0
R1(config-if)#no shut

R2(config)#int fa0/0
R2(config-if)#no shut

So we have now prepared all the interfaces. But traffic wont flow between R3 and R4.


R3#ping 172.16.43.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.43.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

What we need to do now is to bridge the packets within R1 and R2 entering the fastethernet onto the serial interface and vice versa. To do that we need to create a bridge-group but first of all we need to activate a feature that is called “IRB”, integrated routing and bridging. Without that command the bridge-groups wont work.


R1(config)#bridge irb
R1(config)#bridge 1 protocol ieee

R2(config)#bridge irb
R2(config)#bridge 1 protocol ieee

Then add all the participating interfaces to the bridge group.


R1(config)#int s0/0
R1(config-if)#bridge-group 1
R1(config-if)#int fa0/0
R1(config-if)#bridge-group 1

R2(config)#int s0/0
R2(config-if)#bridge-group 1
R2(config-if)#int fa0/0
R2(config-if)#bridge-group 1

We try to ping and see that its not working.


R3#ping 172.16.43.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.43.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

so where is the problem now. Well lets check the bridge-group on one of the WAN routers.


R1#sh bridge

Total of 300 station blocks, 299 free
Codes: P - permanent, S - self

Bridge Group 1:

Address Action Interface Age RX count TX count
c203.1740.0000 forward FastEthernet0/0 0 12 0

Only FastEthernet0/0 is shown here which is quite strange as we have configured s0/0 as well for the bridge-group. Well the thing is that the routers does not know what to do with the packets that enter the fastethernet interface. There is no command that says “when a frame comes in then bridge it to s0/0 with the DLCI xy”. Every packet in a frame-relay network needs a stamp called DLCI and we need to define that.


R1(config-if)#frame-relay map bridge 102 broadcast

R2(config-if)#frame-relay map bridge 102 broadcast

We recocnize that its sill not working.


R3#ping 172.16.43.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.43.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Problem is that Ethernet and Frame-Relay are two completely different access technologies and FastEthernet bridging almost always resides on spanning-tree. On the frame-relay links we have to disable spanning tree for the bridge-group.


R1(config-if)#int s0/0
R1(config-if)#bridge-group 1 spanning-disabled

R2(config-if)#int s0/0
R2(config-if)#bridge-group 1 spanning-disabled

R1#sh bridge

Total of 300 station blocks, 298 free
Codes: P - permanent, S - self

Bridge Group 1:

Address Action Interface Age RX count TX count
c204.1740.0000 forward Serial0/0 0 19 5
c203.1740.0000 forward FastEthernet0/0 0 45 21

There we go. And as we can see on the remote-site routers we have an adjacency.


R3#
*Mar 1 00:33:26.071: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.43.2 on FastEthernet0/0 from LOADING to FULL, Loading Done
R3#ping 172.16.43.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.43.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/48/136 ms


*Mar 1 00:33:26.123: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.43.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
R4(config-if)#do ping 172.16.43.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.43.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/56/116 ms

NOTE:
Under dynamips I observed strange packet loss in that scenario although I think my configuration is correct. Here you can see it.

R3#ping 172.16.43.2 rep 10000

Type escape sequence to abort.
Sending 10000, 100-byte ICMP Echos to 172.16.43.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!.!!!!!!!..............!.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!

When I reboot all devices it works for a while and then it begins sometimes to flap.
Maybe you can test it if you like.

Feel free to comment!
Regards!

Advertisements

About markus.wirth

Living near Limburg in Germany, working as a Network Engineer around Frankfurt am Main.
This entry was posted in CCIE, Frame Relay and tagged , , , , , , , , , , , , , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s